Jump to content


Great value Unlimited Broadband from an award winning provider

Photo

Back Pressure Coolant Forced Out Of Expansion Tank.


  • Please log in to reply
No replies to this topic

#1 HARRY'S GRANDAD

HARRY'S GRANDAD

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 18 November 2018 - 12:02 AM

Hi All
Get one problem sorted and another appears. 1.8tdci Galaxy 2008. 142000 miles.
I had back pressure back in June and ended up having head gasket changed, timing belts both and water pump changed at same time. Since then had coolant problems off and on. Have had it back to garage and he said it looked as if the coolant had soot in it so he removed the water hoses from the egr cooler and joined them together. This appeared to solve my problem when only water, but after he flushed and refilled with anifreeze I have the back pressure problem again. Could it be an air lock?
When I got back this morning from a short run about 10 miles temp guage normal stopped car turned engine off. I checked the expansion tank and coolant was right to the top and had some forced out. I then checked the hoses, bottom hose hot, top hose cold (both under pressure). Then hiss noise as a hose poped at the back of the engine.
I have another question regarding the hose set up on my engine the hose from the thermostat housing is going to the bottom right hand corner of the radiator (stood looking at engine) and my top hose is connected to the pipe going to the water pump. I always thought that the water passed through the thermostat into the top of the radiator and then out of the bottom. Or on my engine the water flows the other way???
Any thoughts would be appreciated.

#2 gregers

gregers

    Eternally ultimate Member

  • Moderator
  • 6,040 posts

Posted 19 November 2018 - 10:55 PM

i put a link on your other post ;) dunno if it helps at all,but have a looksie round that site you might find what your looking for??